Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 135|Reply: 0

rk3399 trying to install linux

[Copy link]

1

Threads

1

Posts

19

Credits

Novice

Rank: 1

Credits
19
Post time 2020-4-22 01:16:08 | Show all posts |Read mode
Hello all.

I have had this nice OrangePi RK3399 for awhile now. Never liked the android system so I replaced it with Armbian. Wasnt easy to get everything running but in the end it ran beautifully. If I remember correctly the only thing I did get running in Armbian was the wifi but it didnt really matter to me at the time.

I had it running for a few months and then i updated the running kernel with some newer one and ever since I cannot get it going again. The Armbian system boots and goes all the way to desktop but there is no usb, no ethernet nor wifi and I cannot change anything nor even check anything. I tried to connect via serial but cannot get up anything. To connect I was using minicom, also tried with putty, also picocom but nothing works. I am using BAUD 1500000, data bits 8, stop bits 1, parity none.

I decided it would be alot easier to install a new system rather then trying to fix the old but then I need the serial connection to start booting from sd. If I remember correctly I have to stop the uboot autoboot process by pressing spacebar or any key but the keyboard doesnt work, what are my options here?

In the flashing procedure I am required to ground TP50265 which I have tried numerous times but it does nothing. I thought I was going crazy after a dozen attempts or so. I even used a multimeter on my paperclip just to make sure it was conducting properly.

I am getting quite lost in trying to figure out what it is I am doing wrong. I just dont get it. I follow all guides and manuals but somehow nothing seems to work.

I would very grateful if someone could possibly point me in the right direction. I think if I just can get the maskrom going, I would have no problem with the rest.
Can it be I could have change the default baud rate? dont know why I would have done that but I can be abit unpreditable at times.
I dont suppose there is a way to erase the emmc by shorting some tip?
I did have a problem with some of my other orangepi that if I was connecting via serial, I would get a prompt but could never type anything, almost like echo was always off no matter which setting I chose. Could these serial connection problems be related to my serial software? thats the reason I had tried so many. Nothing seems to make sense.

As and old RPG fan, I have to say that now I have failed both my intelligence and wisdom checks because I just dont get this.

any pointers are appreciated.
Thanks in advance,
Ragz

You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-5-25 19:48 GMT+8 , Processed in 0.025369 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list