Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: igorpec

All Oranges, Debian and Ubuntu images, updated 12.1.2019

  [Copy link]

9

Threads

632

Posts

4275

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4275
 Author| Post time 2016-2-19 22:50:14 | Show all posts
Edited by igorpec at 2016-2-19 15:51

@y52

Network was broken in Opi+, true and it's already fixed, new image uploaded (v5.02) ... Desktop is not present with this particular image. We need to fix base before releasing desktop - we made test buikd but there are some things which must be fixed before initial release. Generally it's working fine.

15

Threads

105

Posts

387

Credits

Intermediate member

Rank: 3Rank: 3

Credits
387
Post time 2016-2-20 00:19:19 | Show all posts
Thnks for feedback. I shall try the v5.02 to test the network through eth0.
I was also unable to bring the 8189es WIFI to monitor mode.
Is there any special to look for?

9

Threads

632

Posts

4275

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4275
 Author| Post time 2016-2-20 00:42:42 | Show all posts
Not all chips / drivers support monitor mode, especially not among most cheap ones. We probably can't do much about ... If you find better driver, let me know.

Network 100% works now on Orange Pi Plus. I made a test boot.

Add:
This image is not suitable for other H3 boards without selection proper script.bin.

15

Threads

105

Posts

387

Credits

Intermediate member

Rank: 3Rank: 3

Credits
387
Post time 2016-2-20 01:41:32 | Show all posts
The 5.02 version did addressed the eth0 broken interface.
I was able to connect on it with the OPI+.
[   10.144111] gmac0: probed
[   10.144262] gmac0 gmac0: eth0: eth0: PHY ID 001cc915 at 0 IRQ poll (gmac0-0:00)
[   14.140389] PHY: gmac0-0:00 - Link is Up - 100/Full
[   20.930044] eth0: no IPv6 routers present

How does it make, that the eth0 MAC address has been changed to another? My dhcpd was set for another MAC, which is similar across other distributions, while this build brings a different one.

[  964.180200] ==> rtl8188e_iol_efuse_patch
[  964.479050] ADDRCONF(NETDEV_UP): wlan0: link is not ready
[  964.480078] RTL871X: nolinked power save enter
[  997.390428] ==> rtl8188e_iol_efuse_patch
[  997.672004] RTL871X: nolinked power save leave
[ 1000.340114] RTL871X: nolinked power save enter
[ 1067.710122] usb 2-1.2: new high-speed USB device number 3 using sunxi-ehci
[ 1068.278634] ieee80211 phy2: Selected rate control algorithm 'minstrel_ht'
[ 1068.279662] ieee80211 phy2: hwaddr 00:22:3f:da:7f:3e, RTL8187BvE V0 + rtl8225z2, rfkill mask 2

The RTL8187BvE  persists of being unable to switch to monitor mode. Could anything be done to force the monitor mode?


9

Threads

632

Posts

4275

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4275
 Author| Post time 2016-2-20 17:50:40 | Show all posts
How does it make, that the eth0 MAC address has been changed to another? My dhcpd was set for another MAC, which is similar across other distributions, while this build brings a different one.


We are using a different U-boot, mainline v2016.01 ... not the one from Allwinner. Most likely that's the reason of having different MAC.

The RTL8187BvE  persists of being unable to switch to monitor mode. Could anything be done to force the monitor mode?


No ideas.

9

Threads

632

Posts

4275

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4275
 Author| Post time 2016-2-21 03:54:48 | Show all posts
Updated all Orange Pi images.
http://www.armbian.com/download/

Next update will (probably) go trough standard "apt-get upgrade" procedure.

7

Threads

100

Posts

647

Credits

Senior member

Rank: 4

Credits
647
Post time 2016-2-21 18:24:06 | Show all posts
Thank you for the new build.
Question: how can I start xfce (startx fails)

9

Threads

632

Posts

4275

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4275
 Author| Post time 2016-2-21 21:04:27 | Show all posts
Images are not yet supplied with desktop.

This will be released little later when we fix most of low level bugs.

In any case you can try to install it on your own. If you don't need any special 3d or video acceleration, there is no special install. Just use whatever recipe available for Debian Jessie.

0

Threads

21

Posts

112

Credits

Registered member

Rank: 2

Credits
112
Post time 2016-2-22 08:21:17 | Show all posts
Beautiful. Thank you.

  1. U-Boot SPL 2016.03-rc2-armbian (Feb 19 2016 - 19:08:33)
  2. DRAM: 1024 MiB
  3. Trying to boot from MMC


  4. U-Boot 2016.03-rc2-armbian (Feb 19 2016 - 19:08:33 +0000) Allwinner Technology

  5. CPU:   Allwinner H3 (SUN8I)
  6. I2C:   ready
  7. DRAM:  1 GiB
  8. MMC:   SUNXI SD/MMC: 0
  9. *** Warning - bad CRC, using default environment

  10. In:    serial
  11. Out:   serial
  12. Err:   serial
  13. Net:   No ethernet found.
  14. starting USB...
  15. No controllers found
  16. Hit any key to stop autoboot:  0
  17. switch to partitions #0, OK
  18. mmc0 is current device
  19. Scanning mmc 0:1...
  20. Found U-Boot script /boot/boot.scr
  21. 2070 bytes read in 343 ms (5.9 KiB/s)
  22. ## Executing script at 43100000
  23. 0 bytes read in 251 ms (0 Bytes/s)
  24. 12927 bytes read in 861 ms (14.6 KiB/s)
  25. 4826536 bytes read in 5250 ms (897.5 KiB/s)
  26. Kernel image @ 0x46000000 [ 0x000000 - 0x49a5a8 ]
  27. ## Flattened Device Tree blob at 49000000
  28.    Booting using the fdt blob at 0x49000000
  29.    Using Device Tree in place at 49000000, end 4900627e

  30. Starting kernel ...

  31. Uncompressing Linux... done, booting the kernel.

  32. Ubuntu 14.04 LTS orangepipc ttyS0

  33. orangepipc login: root
  34. Password:
  35. Last login: Fri Feb 19 21:45:26 WET 2016 on ttyS0

  36. Welcome to ARMBIAN Ubuntu 14.04 LTS 4.4.2-sunxi

  37. System load:   0.00             Up time:       5 sec
  38. Memory usage:  2 % of 1005Mb    IP:
  39. Usage of /:    9% of 29G

  40. [ 73 updates to install: apt-get upgrade ]

  41. root@orangepipc:~# uname -a
  42. Linux orangepipc 4.4.2-sunxi #3 SMP Fri Feb 19 19:27:07 WET 2016 armv7l armv7l x
  43. root@orangepipc:~#
Copy the Code

2

Threads

16

Posts

203

Credits

Intermediate member

Rank: 3Rank: 3

Credits
203
Post time 2016-2-23 17:46:01 | Show all posts
I've installed Armbian 5.03 on OPI 2 and it looks like it's working quite well
Quick look - wifi works, eth works, still the same duplicated wlan iface like in Loboris image:
  1. $ sudo ifconfig -a

  2. wlan0     Link encap:Ethernet  HWaddr 00:e0:4c:f0:1c:fd
  3.           inet addr:192.168.5.6  Bcast:192.168.5.255  Mask:255.255.255.0
  4.           inet6 addr: fd30:5399:8e1b:0:2e0:4cff:fef0:1cfd/64 Scope:Global
  5.           inet6 addr: fe80::2e0:4cff:fef0:1cfd/64 Scope:Link
  6.           UP BROADCAST RUNNING MULTICAST  MTU:1500  Metric:1
  7.           RX packets:33397 errors:0 dropped:356 overruns:0 frame:0
  8.           TX packets:14745 errors:0 dropped:2 overruns:0 carrier:0
  9.           collisions:0 txqueuelen:1000
  10.           RX bytes:30425175 (29.0 MiB)  TX bytes:2997028 (2.8 MiB)

  11. wlan1     Link encap:Ethernet  HWaddr 02:e0:4c:f0:1c:fd
  12.           BROADCAST MULTICAST  MTU:1500  Metric:1
  13.           RX packets:0 errors:0 dropped:6294 overruns:0 frame:0
  14.           TX packets:0 errors:0 dropped:0 overruns:0 carrier:0
  15.           collisions:0 txqueuelen:1000
  16.           RX bytes:0 (0.0 B)  TX bytes:0 (0.0 B)
Copy the Code


The only thing I've noticed is quite high idle load, about ~1.0, and some proces w1_bus_master1 taking proc time:
  1. top - 10:16:46 up 1 day, 20:02,  2 users,  load average: 1.40, 1.61, 1.39
  2. Tasks:  95 total,   1 running,  94 sleeping,   0 stopped,   0 zombie
  3. %Cpu(s):  0.3 us,  1.5 sy,  0.0 ni, 98.1 id,  0.0 wa,  0.0 hi,  0.1 si,  0.0 st
  4. KiB Mem:   1025324 total,   445192 used,   580132 free,    31204 buffers
  5. KiB Swap:   131068 total,        0 used,   131068 free.   324700 cached Mem

  6.   PID USER      PR  NI    VIRT    RES    SHR S  %CPU %MEM     TIME+ COMMAND
  7.   108 root      20   0       0      0      0 S   5.2  0.0  44:41.76 [w1_bus_master1]
  8. 2645 root      20   0       0      0      0 S   0.3  0.0   6:28.04 [kworker/0:1]
  9.   376 root      20   0       0      0      0 S   0.0  0.0   4:10.97 [RTW_CMD_THREAD]
  10.   107 root      -2   0       0      0      0 S   0.0  0.0   2:15.91 [ksdioirqd/mmc1]
  11.    37 root      rt   0       0      0      0 S   1.6  0.0   1:48.59 [cfinteractive]
Copy the Code

One question - what are supported cpu speeds?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-6-7 17:08 GMT+8 , Processed in 0.030605 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list