please choosego to mobile | Continue to access the PC version
Author: igorpec

All Oranges, Debian and Ubuntu images, updated 12.1.2019

  [Copy link]

1

threads

3

posts

31

credits

Novice

Rank: 1

credits
31
Published in 2015-10-15 15:34:26 | Show all floors
hello igorpeg and frieds i m totaly nab with all this and i try to set up my orange pi pc.  Can i try to install your image ? working on my orange?
Ty for your work

9

threads

641

posts

4380

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4380
 Author| Published in 2015-10-15 16:40:01 | Show all floors
H3 based Oranges are not supported. Only with A20 and A31.

9

threads

641

posts

4380

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4380
 Author| Published in 2016-2-1 19:20:17 | Show all floors
Edited by igorpec at 2016-2-1 12:23

First H3 based Oranges Armbian test builds

- Opi+ and PC
- Debian Jessie, with legacy 3.4.40 and mainline 4.4.1
- Uboot 2016.01
- not ready for end users yet
- serial console only

Feedback is welcomed.

0

threads

7

posts

70

credits

Registered member

Rank: 2

credits
70
Published in 2016-2-5 19:58:36 | Show all floors
Edited by dimmas375 at 2016-2-5 22:04

Tried to boot Orange Pi PC from your image written on SD card by Rufus, but without success. imagewriter crashed under Windows 10. Screen shows nothing, network isn't active.

And your Kernel and image build script on github fails on build image for OPI+ at compiling uboot stage.

9

threads

641

posts

4380

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4380
 Author| Published in 2016-2-6 00:04:12 | Show all floors
1. On Windows 10 you need to use Rufus or similar writer. It's a known problem, written in my FAQ.
2. Network support works only with Opi+ (the one with giga ethernet) and legacy kernel.
3. Compilation breaks, fixing it ... you need to disable uboot-splash.patch in uboot. (lib/patch/u-boot-default and next)

And yes, no screen is normal. We only have serial console for now when using mainline uboot. HDMI support is not done yet.

0

threads

7

posts

70

credits

Registered member

Rank: 2

credits
70
Published in 2016-2-6 07:02:29 | Show all floors
It will be nice if you post link to your FAQ, igorpec.
Well, after you've fixed git repository, image for OPI PC was built successfully, but only with new Vanilla kernel. When trying to build 3.4 kernel, script is terminated after uboot building.
I can't test prebuilt by you and built by myself images because I have no TTL converter yet, sorry.

Will try to get loboris images work with bmp085 again (all I need is bmp085 support, ssh access to the board and debian-based OS, but not successfully atm).

9

threads

641

posts

4380

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4380
 Author| Published in 2016-2-6 17:44:57 | Show all floors
Edited by igorpec at 2016-2-6 10:49

General FAQ: http://www.armbian.com/documentation/

Regarding image. It's based on opensoruce bootloader and stock 3.4.x kernel is fixed that it can be build standard way. Mainline kernel will be/is much much better (for server usage) than kernel used on stock and Loboris images except we don't have network support yet. If you use it with USB wire or wireless network adaptor and serial console than you can already try to use image for server cases.

Build process, both kernels and uboot needs further development and fixing ...

0

threads

7

posts

70

credits

Registered member

Rank: 2

credits
70
Published in 2016-2-6 19:17:29 | Show all floors
Build process, both kernels and uboot needs further development and fixing ...

This why I left feedback here.

I plan to use this board as some kind controller wired to the router, so I won't buy separate WiFi-dongle for this. I prefer to wait while there will be Ethernet support, and migrate to Armbian then. But now I shall write my own programs, services etc.
Good luck with your development work.

9

threads

641

posts

4380

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4380
 Author| Published in 2016-2-14 23:54:43 | Show all floors
Ethernet is present in legacy images, kernel 3.4.110, mainline will come little later ...

1

threads

5

posts

27

credits

Novice

Rank: 1

credits
27
Published in 2016-2-18 15:07:28 | Show all floors
Hi there, I have tried copying the image in Windows and Linux.  When I insert the card into the pi and switch on, the red LED doesn't come on and nothing happens.  Do I need to create a BOOT partition with a uimage and script.bin like the other images I've used?

Many thanks
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list