Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 5249|Reply: 1

USB webcam doesn't work

[Copy link]

1

Threads

2

Posts

23

Credits

Novice

Rank: 1

Credits
23
Post time 2015-10-24 22:07:38 | Show all posts |Read mode
Edited by JRodrigo at 2015-10-24 22:17

I'm trying to use a USB webcam but I can not get it to work properly.

With a Raspberry Pi works perfectly but with Orange Pi PC i have these:

The webcam is detected
  1. ~$ lsusb
  2. ...
  3. Bus 003 Device 003: ID 0bda:5801 Realtek Semiconductor Corp.
Copy the Code
but any video device (like video0) appears on /dev/, i think that have an driver incompatibility with kernel because

  1. ~$ dmesg
  2. ...
  3. [  983.589080] ehci_irq: highspeed device connect
  4. [  983.850062] usb 3-1: new high-speed USB device number 4 using sunxi-ehci
  5. [  984.464628] uvcvideo: disagrees about version of symbol module_layout
Copy the Code
At this point i don't know how to fix it

2

Threads

34

Posts

355

Credits

Intermediate member

Rank: 3Rank: 3

Credits
355
Post time 2015-10-25 05:00:02 | Show all posts
I am struggling with webcams too, but my problem seems to be in a different driver.
Anyways, quick googling of your output showed that your uvcdriver was compiled for a different kernel version.
Here, take a look at a dirty solution: StackOverflow question.
You'll need a HEX editor and it MIGHT work. Might not.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2022-5-23 21:57 GMT+8 , Processed in 0.029350 second(s), 22 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list