please choosego to mobile | Continue to access the PC version
Author: swordfish6975

Openelec Build for OPI PC and 2 now with HW decoding

  [Copy link]

4

threads

1119

posts

8440

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8440
Published in 2015-12-18 14:19:56 | Show all floors
runnerway replied at 2015-12-17 22:46
I will try the new build on OPi PC but i don't except to see any differences using it.I don't use w ...

What can it do?

My first draft which works sometimes:
- no green stripes whatsoever - takes care for all cropping and scaling
- observed CPU load for your VC-1_29.970 video: 6% 0% 0% 0% (faked deinterlacing but completely smooth playback)

However, now I won't have a lot time to put into this. You know, new year and things...

 Author| Published in 2015-12-18 18:07:04 | Show all floors
Edited by swordfish6975 at 2015-12-18 18:29

New Images here  -> https://mega.nz/#F!tt1U0BBI!0ZGsqzJxpS_UWZy0moqNDQ

Not sure what overclocking or not is in the images so take care!


Edit:   Cant seem to build HYH-TBH3

  1. Device Tree Source is not correctly specified.
  2. Please define 'CONFIG_DEFAULT_DEVICE_TREE'
  3. or build with 'DEVICE_TREE=<device_tree>' argument

  4. dts/Makefile:27: recipe for target 'arch/arm/dts/sun8i-h3-hyh-tbh3.dtb' failed
  5. make[2]: *** [arch/arm/dts/sun8i-h3-hyh-tbh3.dtb] Error 1
  6. Makefile:834: recipe for target 'dts/dt.dtb' failed
  7. make[1]: *** [dts/dt.dtb] Error 2
  8. make[1]: Leaving directory '/home/OpenELEC-OPi2/build.OpenELEC-H3.arm-7.0-devel/u-boot-2016.01-rc2'
  9. make: *** [image] Error 1
Copy code


0

threads

41

posts

213

credits

Intermediate member

Rank: 3Rank: 3

credits
213
Published in 2015-12-18 18:20:38 | Show all floors
jernej replied at 2015-12-18 14:19
What can it do?

My first draft which works sometimes:

This is a good teaser.
It's wonderful.

Did you try Adele' VP9 video too?


 Author| Published in 2015-12-18 19:07:32 | Show all floors
Edited by swordfish6975 at 2015-12-18 19:30

small things I have noticed with my new OPi PC image:

1. didn't boot the very first time (3/3 times I wrote to SD)
2. boots fine the second and subsequent times.
3. red LED on the board stays off.
4. seems to boot quicker once openelec splash screen is up?  perhaps takes longer to show up though?


http://pastebin.com/05suYuSR  <-- gets stuck at     ### ERROR ### Please RESET the board ###    this is when I turned it off and back on.

This thread contains more resources

You need to Log in to download or view,No account?    Register

x

0

threads

5

posts

392

credits

Intermediate member

Rank: 3Rank: 3

credits
392
Published in 2015-12-18 21:16:33 | Show all floors
Edited by slayx at 2015-12-18 14:31

I was able to compile the image for OPi Plus and it works very smooth but I am not able to change the screen resolution. I tried to modify the boot.cfg file by adding:
  1. setenv bootargs console=ttyS0,115200 hdmi.audio=EDID:0 boot=/dev/mmcblk0p1 disk=/dev/mmcblk0p2 video=mxcfb0:dev=hdmi,1920x1080M@60,if=RGB24,bpp=32 dmfc=3 consoleblank=0
Copy code

and then recompile the image but the device does not boot at all.

Do you guys know how to change the resolution?


1

threads

90

posts

727

credits

Senior member

Rank: 4

credits
727
Published in 2015-12-19 01:19:59 | Show all floors
slayx replied at 2015-12-18 21:16
I was able to compile the image for OPi Plus and it works very smooth but I am not able to change th ...

you will probably need to edit the fex for the plus.
in particular screen0_output_mode, screen1_output_mode  and fb0_format in the disp_int-section..set these parameter values to 10 and then recompile (or recreate script.bin and copy to SD)

I noticed for the plus these values are currently set at 4 (which is 1280x720 I think)



0

threads

5

posts

392

credits

Intermediate member

Rank: 3Rank: 3

credits
392
Published in 2015-12-19 01:57:40 | Show all floors
lymon replied at 2015-12-18 18:19
you will probably need to edit the fex for the plus.
in particular screen0_output_mode, screen1_ou ...



Thanks lymon.

I've changed:

  1. screen0_output_mode      = 10
Copy code

and it did the trick

3

threads

165

posts

1203

credits

Gold member

Rank: 6Rank: 6

credits
1203
Published in 2015-12-19 17:44:01 | Show all floors
Quick question: each time a new build is released. Do you have to reflash (en thus use new settings)? Or can you somehow update or just update without flashing?

1

threads

90

posts

727

credits

Senior member

Rank: 4

credits
727
Published in 2015-12-19 19:44:50 | Show all floors
Edited by lymon at 2015-12-19 19:53
Dima replied at 2015-12-19 17:44
Quick question: each time a new build is released. Do you have to reflash (en thus use new settings) ...

In most cases you only need to replace the SYSTEM-file on the SD-card if you want to update Openelec, but keep all your old settings/addons/etc.
In some rare case the KERNEL-file also needs to be replaced, but usually only when the kernel has been updated or the config has changed (check if file size is different)

Or, you can use the Openelec backup tool (SYSTEM > OPENELEC > SYSTEM > CREATE SYSTEM AND KODI BACKUP) and after this has finished copy the file xxxxxxxxx.tar file stored in the folder /storage/backup/ to a USB-stick.
Then flash the new Openelec version and restore the backup file (you'll first need to copy it back from USB to the /storage/backup/ folder)





4

threads

1119

posts

8440

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8440
Published in 2015-12-20 00:08:10 | Show all floors
@runnerway,
I did and it is perfectly aligned with screen (no green stripes), however it still crashes because it is crash in codec, not in rendering engine. Maybe same trick as for VC1 will do, however, its weekend and I'm trying to be away from computer

@swordfish,
you must check fritz's repository about failed image, I do not own this device. If U-Boot problem is repeatable you may try to file a bug report there. Every boot on my OPi2 device was perfectly good.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list