Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: swordfish6975

Openelec Build for OPI PC and 2 now with HW decoding

  [Copy link]

4

Threads

1119

Posts

8414

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8414
Post time 2016-5-29 02:58:32 | Show all posts
There is some problem with video, but to me and some other forum members here there are only video artifacts, nothing so severe as video disappering. I'm searching for the reason, which is really probably a kernel issue, but to date, no luck. That's why I didn't put any newer builds/updates.

I already reverted video drivers to older ones, but issue is still there. I'm suspecting that something is underclocked... One big disadvantage fo reverting to older kernel is kswapd issue. I would rather fix this kernel.

1

Threads

76

Posts

519

Credits

Senior member

Rank: 4

Credits
519
Post time 2016-5-29 04:08:39 | Show all posts
Ok,

I am waiting then good luck - it will make many people happy :-)

R

13

Threads

197

Posts

791

Credits

Senior member

Rank: 4

Credits
791
Post time 2016-5-29 04:12:46 | Show all posts
I have no any single issues. Except artifacts on intetlaced videos, due to vsync missing.

1

Threads

23

Posts

103

Credits

Registered member

Rank: 2

Credits
103
Post time 2016-5-29 06:54:49 | Show all posts
somhow i cant bring it up. no hdmi signal, not fetching any ip over lan and uart just does this:
http://pastebin.com/XT0apZqg

  1. [    2.151878] asoc: sndcodec <-> sunxi-codec mapping ok
  2. [    2.158270] [DAUDIO]sunxi-daudio cannot find any using configuration for controllers, return directly!
  3. [    2.168772] [I2S]snddaudio cannot find any using configuration for controllers, return directly!
  4. [    2.178557] [DAUDIO0] driver not init,just return.
  5. [   24.030011] ------------[ cut here ]------------
  6. [   24.035148] WARNING: at kernel/watchdog.c:255 watchdog_timer_fn+0xf0/0x2b4()
  7. [   24.040023] ------------[ cut here ]------------
  8. [   24.040036] WARNING: at kernel/watchdog.c:255 watchdog_timer_fn+0xf0/0x2b4()
  9. [   24.040427] ---[ end trace abc2a992e2d0f5bb ]---
  10. [   24.040002] ---[ end trace abc2a992e2d0f5bc ]---
  11. [   32.030005] INFO: rcu_preempt detected stalls on CPUs/tasks:
  12. [   32.036287]  0: (1 GPs behind) idle=2bb/140000000000000/0 ¦¦J¦
  13. [   32.039999]  2: (1 GPs behind) idle=2b7/140000000000000/0 ¦¦J¦
  14. [   32.039999]  (detected by 3, t=2201 jiffies)
  15. [   32.039999] INFO: Stall ended before state dump start
  16. [   92.140164] INFO: rcu_preempt detected stalls on CPUs/tasks:
  17. [   92.146445]  0: (1 GPs behind) idle=2bb/140000000000000/0 @6¦
  18. [   92.150154]  2: (1 GPs behind) idle=2b7/140000000000000/0 @6¦
  19. [   92.150154]  (detected by 1, t=8212 jiffies)
  20. [   92.150154] INFO: Stall ended before state dump start
Copy the Code



1

Threads

8

Posts

333

Credits

Intermediate member

Rank: 3Rank: 3

Credits
333
Post time 2016-5-30 09:49:02 | Show all posts
jernej, is it possible to make the system turned on after pressing the power button , not when you connect the power cord?

6

Threads

35

Posts

291

Credits

Intermediate member

Rank: 3Rank: 3

Credits
291
Post time 2016-5-30 11:16:55 | Show all posts
what type of usb Wirelles is working with AP mode , i try with few wifi dongles but had no luck to turn on Setting AP mode . any suggestion guys ? thx

4

Threads

1119

Posts

8414

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8414
Post time 2016-5-31 04:56:00 | Show all posts
Xer0 replied at 2016-5-28 23:54
somhow i cant bring it up. no hdmi signal, not fetching any ip over lan and uart just does this:
htt ...

Try another (better) SD card or power supply...

4

Threads

1119

Posts

8414

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8414
Post time 2016-5-31 04:58:21 | Show all posts
ParadoxX27 replied at 2016-5-30 02:49
jernej, is it possible to make the system turned on after pressing the power button , not when you c ...

It is. Definetly by changing source code but I think also with script (GPIO command). However, you will have to do it by yourself. I have too much other work currently

13

Threads

197

Posts

791

Credits

Senior member

Rank: 4

Credits
791
Post time 2016-5-31 18:14:42 | Show all posts
I think it's bad idea. Good idea is to be able to switch on with remote button, but probably not possible.

0

Threads

6

Posts

32

Credits

Novice

Rank: 1

Credits
32
Post time 2016-5-31 18:35:03 | Show all posts
I have an issue on my OpiOne: every 10 seconds there is frame drop (or stutter), it doesn't regard the video format, i have the same issue with xvid, h.264 and h.265.
Googling brought me to this: The problem is related to XBMX/KODI and the CLinuxInputDevices::ReadEvent function. There is a timer which checks at least every 10 seconds for hotplug USB devices.

But i don't know if there is a solution.
Am I the only one having this issue? What can I do?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2022-5-26 22:29 GMT+8 , Processed in 0.037864 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list