please choosego to mobile | Continue to access the PC version
View: 17413|Reply: 15

can't start orange pi

[Copy link]








Rank: 1

Published in 2015-2-21 01:44:15 | Show all floors |Read mode

there is a week I received a mini orangepi and orangepi for testing. At first, none was starting.

I changed the μSD. With μSD class 10 Kingstone, no card starts. With μSD Transcend class 10, the mini-orangepi start and I could install an OS image via orangepi ( image /)

However, orangepi still does not start.

I have 5v power supply - 3A purchased at the same time as the cards on Aliexpress.

Does anyone have an idea to finally start the orangepi?

thank you

Published in 2015-2-21 09:50:21 | Show all floors








Rank: 1

 Author| Published in 2015-2-21 17:39:53 | Show all floors
it is the same procedure for all orangepi (mini, etc ..). The orangepi starting.

So, should I supposed that the delivered orangepi is dead or is there an other possible trick to boot it ?
Published in 2015-2-22 09:58:38 | Show all floors
We have sent board that was tested.








Rank: 1

 Author| Published in 2015-2-23 02:12:06 | Show all floors
zhao_steven replied at 2015-2-22 09:58
We have sent board that was tested.

ok, but why this board (the orangepi doesn't boot) while the mini orangepi works (even with the same µSD and alimentation) ?

So, is there an other tricks with the orangepi ?
Published in 2015-2-23 08:02:59 | Show all floors
Can you test Orange Pi using 5V/3A Charge and connecting HDMI ?







Registered member

Rank: 2

Published in 2015-2-26 21:42:28 | Show all floors
Hello, i had same problem. All my powersupplys where to weak. What i did is used an old PC PSU, because these are very good quality. I stripped off the Purple and Black wire, and solderd an usb connector to it, now i got VERY stable 5v 2a output.
Published in 2015-3-1 04:14:32 | Show all floors
Because Orange Pi need  more telectric current by power charge supply more than Orange Pi mini.  Power charge >1.5A.







Senior member

Rank: 4

Published in 2015-3-2 03:16:39 | Show all floors
I have orange pi mini received from momday and I have had some troubles.

tried different images  and  orange pi crash at few seconds.

to investigate i connected a usb to 232 ttl interface to see what happens, this is one of the outputs:

U-Boot SPL 2015.04-rc1-00004-g7f641d5-dirty (Feb 06 2015 - 15:41:13)
DRAM: 1024 MiB
CPU: 960000000Hz, AXI/AHB/APB: 3/2/2

U-Boot 2015.04-rc1-00004-g7f641d5-dirty (Feb 06 2015 - 15:41:13) Allwinner Technology

CPU:   Allwinner A20 (SUN7I)
I2C:   ready
DRAM:  1015 MiB
*** Warning - bad CRC, using default environment

Reserved 9216kB of RAM for Framebuffer.
In:    serial
Out:   serial
Err:   serial
SATA link 0 timeout.
AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl SATA mode
flags: ncq stag pm led clo only pmp pio slum part ccc apst
Net:   dwmac.1c50000
starting USB...
USB0:   USB EHCI 1.00
scanning bus 0 for devices... 1 USB Device(s) found
USB1:   USB EHCI 1.00
scanning bus 1 for devices... 1 USB Device(s) found
       scanning usb for storage devices... 0 Storage Device(s) found
Hit any key to stop autoboot:  2 ??? 1 ??? 0
switch to partitions #0, OK
mmc0 is current device
Scanning mmc 0:1...
Found U-Boot script /boot/boot.scr
430 bytes read in 276 ms (1000 Bytes/s)
## Executing script at 43100000
50928 bytes read in 263 ms (188.5 KiB/s)
5546680 bytes read in 548 ms (9.7 MiB/s)
Kernel image @ 0x48000000 [ 0x000000 - 0x54a2b8 ]

Starting kernel ...

<6>Booting Linux on physical CPU 0

<6>Initializing cgroup subsys cpuset

<6>Initializing cgroup subsys cpu

<5>Linux version 3.4.106-orangepi (root@kitchen) (gcc version 4.8.2 (Ubuntu/Linaro 4.8.2-16ubuntu4) ) #4 SMP PREEMPT Mon Feb 2 07:33:08 CET 2015

CPU: ARMv7 Processor [410fc074] revision 4 (ARMv7), cr=10c5387d

CPU: PIPT / VIPT nonaliasing data cache, VIPT aliasing instruction cache

Machine: sun7i

<6>Memory Reserved:

<6>        SYS  : 0x43000000 - 0x4300ffff  (  64 kB)

<6>        LCD  : 0x44000000 - 0x44ffffff  (  16 MB)

Memory policy: ECC disabled, Data cache writealloc

<6>sunxi: Allwinner A20 (AW1651/sun7i) detected.

<7>On node 0 totalpages: 259840

<7>free_area_init_node: node 0, pgdat c0a6eb40, node_mem_map d0000000

<7>  DMA zone: 512 pages used for memmap

<7>  DMA zone: 0 pages reserved

<7>  DMA zone: 65024 pages, LIFO batch:15

<7>  Normal zone: 1008 pages used for memmap

<7>  Normal zone: 128016 pages, LIFO batch:31

<7>  HighMem zone: 510 pages used for memmap

<7>  HighMem zone: 64770 pages, LIFO batch:15

<6>ERCPU: Embedded 8 pages/cpu @d07f7000 s8256 r8192 d16320 u32768

<7>pcpu-alloc: s8256 r8192 d16320 u32768 alloc=8*4096<c>

<7>pcpu-alloc: <c>[0] <c>0 <c>[0] <c>1 <c>

Built 1 zonelists in Zone order, mobility grouping on.  Total pages: 257810

<5>Kernel command line: console=tty1 root=/dev/mmcblk0p1 rootwait sunxi_ve_mem_reserve=0 sunxi_g2d_mem_reserve=0 sunxi_no_mali_mem_reserve sunxi_fb_mem_reserve=16 disp.screen0_output_mode=EDID:1280x720p60 panic=10 consoleblank=0

<6>ID hash table entries: 4096 (order: 2, 16384 bytes)

<6>Dentry cache hash table entries: 131072 (order: 7, 524288 bytes)

<6>Inode-cache hash table entries: 65536 (order: 6, 262144 bytes)

<6>allocated 2078720 bytes of page_cgroup

<6>please try 'cgroup_disable=memory' option if you don't want memory cgroups

<6>Memory: 1015MB = 1015MB total

<5>Memory: 999236k/999236k available, 40124k reserved, 261120K highmem

<5>Virtual kernel memory layout:

    vector  : 0xffff0000 - 0xffff1000   (   4 kB)

    fixmap  : 0xfff00000 - 0xfffe0000   ( 896 kB)

    vmalloc : 0xf0000000 - 0xff000000   ( 240 MB)

    lowmem  : 0xc0000000 - 0xef800000   ( 760 MB)

    pkmap   : 0xbfe00000 - 0xc0000000   (   2 MB)

    modules : 0xbf000000 - 0xbfe00000   (  14 MB)

      .text : 0xc0008000 - 0xc09c5aec   (9975 kB)

      .init : 0xc09c6000 - 0xc09fe040   ( 225 kB)

      .data : 0xc0a00000 - 0xc0a7ea28   ( 507 kB)

       .bss : 0xc0a7ea4c - 0xc0c536c0   (1876 kB)


<6>gpiochip_add: registered GPIOs 1 to 88 on device: A1X_GPIO

<5>SCSI subsystem initialized

<7>libata version 3.00 loaded.

<6>usbcore: registered new interface driver usbfs

<6>usbcore: registered new interface driver hub

<6>usbcore: registered new device driver usb

<6>Linux media interface: v0.10

<6>Linux video capture interface: v2.00

<6>Advanced Linux Sound Architecture Driver Version 1.0.25.

<6>Switching to clocksource arch_sys_counter

<6>cfg80211: Calling CRDA to update world regulatory domain

<5>FS-Cache: Loaded

<6>CacheFiles: Loaded


WRN287(drivers/usb/sunxi_usb/manager/usb_manager.c):ERR: det_vbus pin is invaild

WRN426(drivers/usb/sunxi_usb/manager/usb_manager.c):ERR: check_usb_board_info failed

WRN480(drivers/usb/sunxi_usb/manager/usb_manager.c):ERR: get_usb_cfg failed

[sw_hcd0]: usb host driver initialize........

[sw_udc]: udc_init: version 20080411

<6>NET: Registered protocol family 2

<6>IP route cache hash table entries: 32768 (order: 5, 131072 bytes)

<6>TCP established hash table entries: 131072 (order: 8, 1048576 bytes)

<6>TCP bind hash table entries: 65536 (order: 7, 786432 bytes)

<6>TCP: Hash tables configured (established 131072 bind 65536)

<6>TCP: reno registered

<6>UDP hash table entries: 512 (order: 2, 16384 bytes)

<6>UDP-Lite hash table entries: 512 (order: 2, 16384 bytes)

<6>NET: Registered protocol family 1

<6>RPC: Registered named UNIX socket transport module.

<6>RPC: Registered udp transport module.

<6>RPC: Registered tcp transport module.

<6>RPC: Registered tcp NFSv4.1 backchannel transport module.

<6>audit: initializing netlink socket (disabled)

<5>type=2000 audit(0.374:1): initialized

highmem bounce pool size: 64 pages

<5>VFS: Disk quotas dquot_6.5.2

Dquot-cache hash table entries: 1024 (order 0, 4096 bytes)

<6>squashfs: version 4.0 (2009/01/31) Phillip Lougher

<5>NFS: Registering the id_resolver key type

<6>NTFS driver 2.1.30 [Flags: R/W].

<6>fuse init (API version 7.18)

<6>SGI XFS with ACLs, security attributes, large block/inode numbers, no debug enabled

<6>Btrfs loaded

<6>msgmni has been set to 1441

<6>alg: No test for stdrng (krng)

<6>Block layer SCSI generic (bsg) driver version 0.4 loaded (major 252)

<6>io scheduler noop registered

<6>io scheduler deadline registered

<6>io scheduler cfq registered (default)

<6>sunxi disp driver loaded (/dev/disp api 1.0)

<6>Serial: 8250/16550 driver, 8 ports, IRQ sharing disabled

<6>[uart]: used uart info.: 0x8d

<6>[uart]: serial probe 0 irq 33 mapbase 0x01c28000

<6>sunxi-uart.0: ttyS0 at MMIO 0x1c28000 (irq = 33) is a U6_16550A

<6>[uart]: serial probe 2 irq 35 mapbase 0x01c28800

<6>sunxi-uart.2: ttyS1 at MMIO 0x1c28800 (irq = 35) is a U6_16550A

<6>[uart]: serial probe 3 irq 36 mapbase 0x01c28c00

<6>sunxi-uart.3: ttyS2 at MMIO 0x1c28c00 (irq = 36) is a U6_16550A

<6>[uart]: serial probe 7 irq 52 mapbase 0x01c29c00

<6>sunxi-uart.7: ttyS3 at MMIO 0x1c29c00 (irq = 52) is a U6_16550A

<7>G2D: drv_g2d_init

<6>G2D: Module initialized.major:250

<6>brd: module loaded

<6>loop: module loaded

nand driver is disabled

<3>gpio count < =0 ,gpio_count is: 0

<6>sw_ahci sw_ahci.0: controller can't do PMP, turning off CAP_PMP

<6>ahci: SSS flag set, parallel bus scan disabled

<6>sw_ahci sw_ahci.0: AHCI 0001.0100 32 slots 1 ports 3 Gbps 0x1 impl platform mode

<6>sw_ahci sw_ahci.0: flags: ncq sntf stag pm led clo only pio slum part ccc

<6>scsi0 : sw_ahci_platform

<6>ata1: SATA max UDMA/133 mmio [mem 0x01c18000-0x01c18fff] port 0x100 irq 88

<6>[spi-inf] Found 2 spi devices in config files

<6>[spi-inf] boards num modalias         max_spd_hz       bus_num  cs   mode

<6>[spi-inf] spi_board0 irq gpio not used

<6>[spi-inf] 0          spidev           12000000         0        0    0x3   

<6>[spi-inf] spi_board1 irq gpio not used

<6>[spi-inf] 1          spidev           12000000         0        1    0x3   

<6>[spi-inf] sun7i_spi_probe: sun7i spi probe<6>[spi-inf] sun7i_spi_probe: spi0 dma type: normal

<6>[spi-inf] bus num = 0, spi used = 3

<6>[spi-inf] sun7i_spi_probe: spi0 cs bitmap: 0x3

<6>[spi-inf] sun7i_spi_set_mclk: spi0 source = sdram_pll_p, src_clk = 432000000, mclk 108000000

<6>sun7i-spi sun7i-spi.0: master is unqueued, this is deprecated

<6>[spi-inf] sun7i_spi_setup: enter, bpw: 8, mshz: 12000000, mode: 3

<6>[spi-inf] sun7i_spi_setup: enter, bpw: 8, mshz: 12000000, mode: 3

<6>[spi-inf] sun7i_spi_probe: reuuimlla's SoC SPI Driver loaded for Bus SPI0 with 2 Slaves at most

<6>[spi-inf] sun7i_spi_probe: spi0 driver probe succeed, base f0130000, irq 42, dma_id_rx 24, dma_id_tx 24

<6>bonding: Ethernet Channel Bonding Driver: v3.7.1 (April 27, 2011)

<4>emac_init fetch emac using configuration failed

<6>emac driver is disabled

<4>eth%d: device MAC address 02:59:06:00:cd:d9

gmac_para gpio count is 18

[gmac]: sun6i_gmac platform driver registration completed

<6>PP generic driver version 2.4.2

<6>PP BSD Compression module registered

<6>PP Deflate Compression module registered

<6>PP MPPE Compression module registered

<6>NET: Registered protocol family 24

<6>ehci_hcd: USB 2.0 'Enhanced' Host Controller (EHCI) Driver

<6>ohci_hcd: USB 1.1 'Open' Host Controller (OHCI) Driver

[sw-ehci1]: open clock

[sw-ehci1]: Set USB Power ON


every time when usb power goes ON, board restart or hangs.

I tried several power charger , via jack  and via microusb with same results.
finally i tried a 5A old power supply, and for first time I board has booted fine.

I can confirm you need a strong power supply to start.







Senior member

Rank: 4

Published in 2015-3-2 03:32:44 | Show all floors
I see on board Orange pi mini, 2  solder points labeled BAT+ and BAT-, also  in pdf schematics this points are connected to power manager IC, can you confirm if we can connect a lithium battery ?
thnx in advanced
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list