Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: fsmoke

[SOLVED] Tvout

[Copy link]

4

Threads

1128

Posts

7383

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7383
Post time 2016-4-26 05:21:27 | Show all posts
fsmoke replied at 2016-4-25 22:07
I decide to rebuild all from your new sources, but my build stoped on gcc step with strange issue: ...

Strange, I build everything from scratch few days ago and it worked.  Remove all build folders and try again...

1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-4-30 18:16:08 | Show all posts
at last i tested tvout with latest build i'ev got first results

It's on tv tuner board



And on real tv hardware



As you can see with splash screen all ok - but it's needed to be redrawn(or prograppatically resized)for tv aspect. Unlike splash - main stuff picture aligned to the top of the screen, and on real hw tv it's cropped.

PS
We need to test it with ntsc mode too...

4

Threads

1128

Posts

7383

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7383
Post time 2016-4-30 18:35:32 | Show all posts
Can you explain your modifications?

1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-4-30 18:56:38 | Show all posts
Absolutely nothing unusual

1)I downloaded latest sources from 28.04.2016.
2) fix opipc.fex to tv(2) mode pal(11) and disp_mode(1)
.....
[disp_init]
disp_init_enable = 1
disp_mode = 1
screen0_output_type = 3
screen0_output_mode = 10
screen1_output_type = 2
screen1_output_mode = 11
fb0_format = 0
fb0_width = 0
fb0_height = 0
fb1_format = 0
fb1_width = 0
fb1_height = 0
.....
2)start to build it
3)when kernel sorurces already fetched but still not builded - apply your patch(post no=19) or just uncomment tve_clk_enable in drivers/video/sunxi/disp2/tv/drv_tv.c(as you tell me earlier)
4)wait to the end of build
5)write img to flash
6)profit

May be your device doesn't support pal - try to ntsc(screen1_output_mode = 14)

1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-4-30 19:00:49 | Show all posts
Edited by fsmoke at 2016-4-30 20:17

By the way i think you may already include kernel patch(about tve_clk_enable) to the main source branch. i think nothing will no longer be edited here.

1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-4-30 19:33:29 | Show all posts
Edited by fsmoke at 2016-4-30 19:36

Brilliant!!!! we did it !!



i just swich it to NTSC mode (screen1_output_mode = 14) and finally got fullscreen picture. later i will try to setup aspect inside kodi. And little cropping also exists...

PS
Strange thing - on my computer tv board - i have no signal when ntsc mode is turned on, it seems my tv tuner supports only pal signal. It is again about your TV device - may be you got distorted picture cos your device does not support pal.

4

Threads

1128

Posts

7383

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7383
Post time 2016-4-30 20:28:01 | Show all posts
Edited by jernej at 2016-4-30 18:18

What about video playback? Does it work or is there only black screen?

I'm a bit confused, is patch needed or not?

EDIT: Now that I read everything again, I see that patch is needed.

1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-5-1 01:47:13 | Show all posts
jernej replied at 2016-4-30 20:28
What about video playback? Does it work or is there only black screen?

I'm a bit confused, is patch ...

No playback haven't tested yet. Patch needed only for uncommenting tve_clk_enable line.
Changing fb0 to fb1 in kodi NOT NEEDED!


By the way you must check your cable - it must be the same as picture below




1

Threads

32

Posts

173

Credits

Registered member

Rank: 2

Credits
173
 Author| Post time 2016-5-1 02:05:16 | Show all posts
jernej replied at 2016-4-30 20:28
What about video playback? Does it work or is there only black screen?

I'm a bit confused, is patch ...

I tested playback right now - just black screen . Have you any ideas how it will could be fixed?

4

Threads

1128

Posts

7383

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
7383
Post time 2016-5-1 02:13:56 | Show all posts
Yes, check post #14. Just ignore those which are about fb0. But until I manage to sort issues with my analog display + cable, I won't be able to actively help.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2019-8-22 08:39 GMT+8 , Processed in 0.029227 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list