please choosego to mobile | Continue to access the PC version
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

1

threads

39

posts

137

credits

Registered member

Rank: 2

credits
137
Published in 2015-6-27 07:06:12 | Show all floors
Ok,
I saw no mention about cross compiling so I assume it was native.  I will build on an x86 linux host.

Thanks.

10

threads

448

posts

4560

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
4560
 Author| Published in 2015-6-27 07:08:01 | Show all floors
Edited by loboris at 2015-6-27 07:11
roblad replied at 2015-6-27 05:28
Hi,

Could you prepare image for opi+ (that procedure with upload modules and writing dd as you spec ...

OPI2 and OPI+ images are identical, except for u-boot and kernel.

Only difference between emmc and sd card booting is that u-boot must know where to load rootfs from, and rootfs must know which partition to mount.
That's why I've asked you (twice) to tell me as which device you see emmc (is it mmcblk1  or something else ?)

I also have wlan0 and wlan1 on OPI2, but what is the problem with that if it works ?

1

threads

76

posts

519

credits

Senior member

Rank: 4

credits
519
Published in 2015-6-27 07:23:34 | Show all floors
Hi,


I am not able to start imgs from your mega in opi+ it hangs in boot playmouth-... error 1

2

threads

53

posts

1532

credits

Gold member

Rank: 6Rank: 6

credits
1532
Published in 2015-6-27 15:58:23 | Show all floors
If you using Ubuntu images on OPI+, you have to wait for about 90 seconds.
See
http://www.orangepi.org/orangepi ... 7&fromuid=16899
and
http://www.orangepi.org/orangepi ... 8&fromuid=16899

1

threads

76

posts

519

credits

Senior member

Rank: 4

credits
519
Published in 2015-6-27 18:24:00 | Show all floors
Hi,

It starts a long time wifi cause destroing my wifi router durring boot FTDI is not visable, emmc is not visable dd boot and u-boot for OPI+ destroing file system. Starts after long time with uImage for opi+ there is a horror. Sometimes it starts sometimes not, dd foru-boot and boot0 estroing card in OPI+

1

threads

76

posts

519

credits

Senior member

Rank: 4

credits
519
Published in 2015-6-27 19:28:35 | Show all floors
Hi,


J did every thing from begining and right now hangs on cleaning X2go -there is everything not compatible in OPI+

2

threads

37

posts

382

credits

Intermediate member

Rank: 3Rank: 3

credits
382
Published in 2015-6-27 19:54:58 | Show all floors
I believe steven have mailed a opi plus to loboris... He can better test the img for opi plus when he received... Let all be patient...

Cheers

1

threads

76

posts

519

credits

Senior member

Rank: 4

credits
519
Published in 2015-6-27 20:00:45 | Show all floors
ok,

But probably I will buy next rpi2 and ssd - it is a horror after 1 week, OPI+ should not be sold before  system will be ready.

1

threads

39

posts

137

credits

Registered member

Rank: 2

credits
137
Published in 2015-6-27 22:18:09 | Show all floors
Still no success on building my own kernel. Just trying to build the source modified with your changes and no changes of my own.
Here are the errors I get:

  CC      arch/arm/mach-sunxi/power/brom/resume_head.o
arm-linux-gnueabi-gcc: error: unrecognized command line option ‘--min_array_alignment=4’
arm-linux-gnueabi-gcc: error: unrecognized command line option ‘--no_unaligned_access’
make[3]: *** [arch/arm/mach-sunxi/power/brom/resume_head.o] Error 1
make[2]: *** [arch/arm/mach-sunxi/power/brom/resumes.code] Error 2
make[1]: *** [arch/arm/mach-sunxi/power] Error 2
make: *** [arch/arm/mach-sunxi] Error 2
make: *** Waiting for unfinished jobs....

It contiunes with several hundered lines (Some warnings) then stops here:
  LD      fs/nfsd/built-in.o
  LD      fs/built-in.o
  DEPMOD  3.4.39
cp: cannot stat ‘arch/arm/boot/uImage’: No such file or directory

Is something still missing or is my environment not right yet.
Running an x86 install of ubuntustudio:
mark@mark-ubuntu:~$ uname -a
Linux mark-ubuntu 3.16.0-34-lowlatency #47~14.04.1-Ubuntu SMP PREEMPT Fri Apr 10 18:18:14 UTC 2015 i686 athlon i686 GNU/Linux

Any ideas?

1

threads

76

posts

519

credits

Senior member

Rank: 4

credits
519
Published in 2015-6-27 23:21:43 | Show all floors
Hi,

I did some tests, and the main problem is in uImages I used all file system from zacho_seven (dir structure) and works but without emmc and FTDI.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list