Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: loboris

Linux Distributions for Orange PI H3 boards

  [Copy link]

10

Threads

448

Posts

4252

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4252
 Author| Post time 2015-8-9 02:40:14 | Show all posts
drizzle replied at 2015-8-8 01:08
hey loboris

thanks for this contribution.

Downoad lichee.tar.gz from Mega, everything is there....

1

Threads

15

Posts

81

Credits

Registered member

Rank: 2

Credits
81
Post time 2015-8-11 07:05:33 | Show all posts
My first post on these forums.

First off I am excited to see folks like loboris actively working on getting these boards to their full potential on the software side.

At first I was a bit disappointed to see others complaining about lack of more developed software for this board, but since the board is new, and the price is low I am willing to deal with a few bumps in the road.

For $25, I am thrilled to see a quad core 1.6ghz cpu with 1gb of ram...

I'm pretty sure I will be installing the base vivid image onto my orange pi mini 2 once it arrives. (In the mail now). I am enticed by the low ram usage, as I want to use every last but of ram possible for my other application. I wont be using any GUI, I plan to only use SSH and other remote access as this orange pi will be used as a web server and mincraft server for me. This will be my first ARM SBC, I cant wait to play around with it. I have a little experience using x86 lunix vps servers, but thats about it for my lunix experience.  

I look forward to being a part of this community as I learn more.

18

Threads

303

Posts

8397

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8397
Post time 2015-8-12 09:38:24 | Show all posts
Edited by jacer at 2015-8-12 09:39

Hello, lobris. I tried your build image with Orange Pi PC. I got only one USB port working, the other two USB ports won`t work, b.t.w. the OPI PC only has three USB ports. And I installed the LXDE desktop but got an dependency error shows below, but still works.
  1. The following packages have unmet dependencies:
  2. x2goagent : Depends:         nxagent (>= 2:3.5.0.32-0x2go1.1) but 2:3.5.0.28-0x2go1.1 is to be installed
  3. E: Unable to correct problems, you have held broken packages.
  4. E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/libc/libcpan-meta-perl/libcpan-meta-perl_2.142690-1_all.deb  Size mismatch
  5. E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/libm/libmodule-build-perl/libmodule-build-perl_0.421000-2_all.deb  Size mismatch
  6. E:Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/libr/libregexp-common-perl/libregexp-common-perl_2013031301-1_all.deb  Size mismatch
  7. E: Failed to fetch http://ports.ubuntu.com/ubuntu-ports/pool/main/libs/libsoftware-license-perl/libsoftware-license-perl_0.103010-3_all.deb  Size mismatch
Copy the Code
Tried to download four packages above and install locally with dpkg -i but still won`t install.
I tried to install Chromium-Browser but failed with quite a few errors shows below.
  1. The following packages have unmet dependencies:
  2. chromium-browser : Depends: libnspr4 (>= 2:4.9-2~) but it is not going to be installed or
  3.                              libnspr4-0d (>= 1.8.0.10) but it is not going to be installed
  4.                     Depends: libnss3 (>= 2:3.14.3) but it is not going to be installed
  5.                     Depends: xdg-utils but it is not going to be installed
  6.                     Depends: chromium-codecs-ffmpeg-extra (>= 0.6) but it is not going to be installed or
  7.                              chromium-codecs-ffmpeg (>= 0.6) but it is not going to be installed
  8.                     Recommends: chromium-browser-l10n but it is not going to be installed
  9. libcpan-meta-perl : Depends: perl but it is not going to be installed
  10.                      Depends: perl (>= 5.15.0) but it is not going to be installed or
  11.                               libjson-pp-perl
  12.                      Depends: perl (>= 5.17.1) but it is not going to be installed or
  13.                               libcpan-meta-requirements-perl
  14.                      Depends: perl (>= 5.17.1) but it is not going to be installed or
  15.                               libcpan-meta-yaml-perl
  16.                      Depends: perl (>= 5.19.10) but it is not going to be installed or
  17.                               libparse-cpan-meta-perl (>= 1.4414)
  18. libmodule-build-perl : Depends: perl but it is not going to be installed
  19.                         Depends: libperl-ostype-perl
  20.                         Depends: perl (>= 5.11.2) but it is not going to be installed or
  21.                                  libextutils-cbuilder-perl
  22.                         Depends: perl (>= 5.12) but it is not going to be installed or
  23.                                  libextutils-parsexs-perl
  24.                         Depends: perl (>= 5.13.9) but it is not going to be installed or
  25.                                  libmodule-metadata-perl
  26.                         Depends: perl (>= 5.13.9) but it is not going to be installed or
  27.                                  libversion-perl (>= 1:0.8700)
  28.                         Recommends: libarchive-tar-perl
  29.                         Recommends: libmodule-signature-perl but it is not going to be installed
  30.                         Recommends: libpod-readme-perl but it is not going to be installed
  31. libregexp-common-perl : Depends: perl but it is not going to be installed
  32. libsoftware-license-perl : Depends: libdata-section-perl but it is not going to be installed
  33.                             Depends: libsub-install-perl but it is not going to be installed
  34.                             Depends: libtext-template-perl but it is not going to be installed
  35.                             Depends: perl but it is not going to be installed
  36. E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Copy the Code
I tried to install synaptic also failed with below errors.
  1. The following packages have unmet dependencies:
  2. libcpan-meta-perl : Depends: perl but it is not going to be installed
  3.                      Depends: perl (>= 5.15.0) but it is not going to be installed or
  4.                               libjson-pp-perl
  5.                      Depends: perl (>= 5.17.1) but it is not going to be installed or
  6.                               libcpan-meta-requirements-perl
  7.                      Depends: perl (>= 5.17.1) but it is not going to be installed or
  8.                               libcpan-meta-yaml-perl
  9.                      Depends: perl (>= 5.19.10) but it is not going to be installed or
  10.                               libparse-cpan-meta-perl (>= 1.4414)
  11. libmodule-build-perl : Depends: perl but it is not going to be installed
  12.                         Depends: libperl-ostype-perl
  13.                         Depends: perl (>= 5.11.2) but it is not going to be installed or
  14.                                  libextutils-cbuilder-perl
  15.                         Depends: perl (>= 5.12) but it is not going to be installed or
  16.                                  libextutils-parsexs-perl
  17.                         Depends: perl (>= 5.13.9) but it is not going to be installed or
  18.                                  libmodule-metadata-perl
  19.                         Depends: perl (>= 5.13.9) but it is not going to be installed or
  20.                                  libversion-perl (>= 1:0.8700)
  21.                         Recommends: libarchive-tar-perl
  22.                         Recommends: libmodule-signature-perl but it is not going to be installed
  23.                         Recommends: libpod-readme-perl but it is not going to be installed
  24. libregexp-common-perl : Depends: perl but it is not going to be installed
  25. libsoftware-license-perl : Depends: libdata-section-perl but it is not going to be installed
  26.                             Depends: libsub-install-perl but it is not going to be installed
  27.                             Depends: libtext-template-perl but it is not going to be installed
  28.                             Depends: perl but it is not going to be installed
  29. E: Unmet dependencies. Try 'apt-get -f install' with no packages (or specify a solution).
Copy the Code
Any fix, dude? I attach below with the lxde_install log.


This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

5

Threads

355

Posts

2327

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
2327
Post time 2015-8-12 14:33:40 | Show all posts
@jacer you have the "new" orange pi pc?
if yes, from where you buyed it?
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

10

Threads

448

Posts

4252

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4252
 Author| Post time 2015-8-12 15:39:07 | Show all posts
jacer replied at 2015-8-12 02:38
Hello, lobris. I tried your build image with Orange Pi PC. I got only one USB port working, the othe ...

Does your install-vivid.log (created after base install) has any errors?

Check you /etc/apt/sources.list, it must look like this:
deb http://ports.ubuntu.com/ubuntu-ports/ vivid main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ vivid main restricted universe multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ vivid-updates main restricted universe multiverse
deb-src http://ports.ubuntu.com/ubuntu-ports/ vivid-updates main restricted universe multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ vivid-security main restricted universe multiverse
deb http://ports.ubuntu.com/ubuntu-ports/ vivid-backports main restricted universe multiverse

deb http://debian.xypron.de/ unstable/all/
deb http://debian.xypron.de/ unstable/armhf/
Try to run:
  1. apt-get clean
  2. apt-get update
  3. apt-get install -f
  4. apt-get upgrade
Copy the Code
all packages should be installed without errors.

Where have you got Orange Pi PC, it probably have different fex, that's could be why USB ports are not working correctly.

18

Threads

303

Posts

8397

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8397
Post time 2015-8-12 16:39:11 | Show all posts
Edited by jacer at 2015-8-12 17:07
loboris replied at 2015-8-12 15:39
Does your install-vivid.log (created after base install) has any errors?

Check you /etc/apt/sourc ...

The source list is same as yours. I didn`t check the install_vivid.log I used win32imagewriter to flash the image to TF card. And it boots to the console. Running the sudo install_lxde took me a night. And I found the logout button is not working too. I cannot even install Chromium-browser. B.t.w. I got Orange Pi PC from Zhao, I am in China, it is a beta board which I applied. It only has three USB ports and need some tweaking. I tried these commands below and none working. I flashed the official 0.9 version with Lubuntu 14.04 and it has Chromium builtin and it works. But still one USB port and the resolution cannot change. And the kill cpu3 issue is there with heatsink temp at 70.
  1. apt-get clean
  2. apt-get update
  3. apt-get install -f
  4. apt-get upgrade
Copy the Code
  1. orangepi@orangepi:~$ nproc
  2. 3
  3. orangepi@orangepi:~$ cat /sys/devices/system/cpu/online
  4. 0-2
  5. orangepi@orangepi:~$ cat /sys/class/thermal/thermal_zone0/temp
  6. 70
  7. orangepi@orangepi:~$ cat /sys/class/thermal/thermal_zone1/temp
  8. 70
Copy the Code


5

Threads

355

Posts

2327

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
2327
Post time 2015-8-12 17:37:43 | Show all posts
@jacer
If you are in cina, probably the connections to the outside are not very reliable.
Thats why you have maybe broken packages.
I would adapt /etc/apt/sources.list and use some cinese mirror.
For the usb ports on the OP PI PC you need a different config.fex.
Boards:
orangepi plus, olinuxino A20, cubieboard A10, mele A2000 .....

18

Threads

303

Posts

8397

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8397
Post time 2015-8-12 20:26:19 | Show all posts
Edited by jacer at 2015-8-12 20:36
fritz replied at 2015-8-12 17:37
@jacer
If you are in cina, probably the connections to the outside are not very reliable.
Thats why  ...

@fritz You are right. I noticed some connection timeout when downloading some package. I tried to use a command line version shadowsocks to finish the lxde desktop installation but it won`t run. There is no Chinese server to update these packages. Any idea how to solve this? I dunno how to config it for the other two USB ports. Maybe need new uImage boot0 uboot also.

10

Threads

448

Posts

4252

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
4252
 Author| Post time 2015-8-13 02:10:50 | Show all posts
jacer replied at 2015-8-12 13:26
@fritz You are right. I noticed some connection timeout when downloading some package. I tried to u ...

You can download complete Mate or Xfce image from the Mega link in the 1st post. It is only 350M, it is less than you have to download when installing with script...
Installation of the LXDE desktop with the script should finish in about 30 minutes, Mate and XFCE in about 60 minutes ...
I'll build the kernel and u-boot when I'll have the config.fex for the board.

18

Threads

303

Posts

8397

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
8397
Post time 2015-8-14 23:10:32 From the mobile phone | Show all posts
loboris replied at 2015-8-13 02:10
You can download complete Mate or Xfce image from the Mega link in the 1st post. It is only 350M,  ...

I think I will wait for Zhao to release an OPi PC version. I expect the GPU VPU working on Linux.
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-12-3 02:00 GMT+8 , Processed in 0.035329 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list