Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
View: 708|Reply: 3

rk3399 trying to install linux

[Copy link]

1

Threads

1

Posts

19

Credits

Novice

Rank: 1

Credits
19
Post time 2020-4-22 01:16:08 | Show all posts |Read mode
Hello all.

I have had this nice OrangePi RK3399 for awhile now. Never liked the android system so I replaced it with Armbian. Wasnt easy to get everything running but in the end it ran beautifully. If I remember correctly the only thing I did get running in Armbian was the wifi but it didnt really matter to me at the time.

I had it running for a few months and then i updated the running kernel with some newer one and ever since I cannot get it going again. The Armbian system boots and goes all the way to desktop but there is no usb, no ethernet nor wifi and I cannot change anything nor even check anything. I tried to connect via serial but cannot get up anything. To connect I was using minicom, also tried with putty, also picocom but nothing works. I am using BAUD 1500000, data bits 8, stop bits 1, parity none.

I decided it would be alot easier to install a new system rather then trying to fix the old but then I need the serial connection to start booting from sd. If I remember correctly I have to stop the uboot autoboot process by pressing spacebar or any key but the keyboard doesnt work, what are my options here?

In the flashing procedure I am required to ground TP50265 which I have tried numerous times but it does nothing. I thought I was going crazy after a dozen attempts or so. I even used a multimeter on my paperclip just to make sure it was conducting properly.

I am getting quite lost in trying to figure out what it is I am doing wrong. I just dont get it. I follow all guides and manuals but somehow nothing seems to work.

I would very grateful if someone could possibly point me in the right direction. I think if I just can get the maskrom going, I would have no problem with the rest.
Can it be I could have change the default baud rate? dont know why I would have done that but I can be abit unpreditable at times.
I dont suppose there is a way to erase the emmc by shorting some tip?
I did have a problem with some of my other orangepi that if I was connecting via serial, I would get a prompt but could never type anything, almost like echo was always off no matter which setting I chose. Could these serial connection problems be related to my serial software? thats the reason I had tried so many. Nothing seems to make sense.

As and old RPG fan, I have to say that now I have failed both my intelligence and wisdom checks because I just dont get this.

any pointers are appreciated.
Thanks in advance,
Ragz

2

Threads

11

Posts

70

Credits

Registered member

Rank: 2

Credits
70
Post time 2020-7-12 12:06:42 | Show all posts
3 months late and all but..

This sounds a lot like the issue I had: http://www.orangepi.org/orangepi ... &extra=page%3D1

Unfortunately I don't have a good fix aside from taking a dump of the emmc from another board and flashing it to the one with issues.. Just glad I had a spare..

31

Threads

251

Posts

1156

Credits

Gold member

Rank: 6Rank: 6

Credits
1156
Post time 2020-7-10 15:04:58 | Show all posts
Have you tried just making the SD card with a fresh OS and booting from it?  
Thanks  [url=http://www.orangepi.org/orangepibbsen/static/image/smiley/default/biggrin.gif]http://ww

31

Threads

251

Posts

1156

Credits

Gold member

Rank: 6Rank: 6

Credits
1156
Post time 2020-7-12 20:00:18 | Show all posts
Ahhh, sounds good.   Indeed it was late.  ;-)  I just noticed it.   This seems a user ran message board.  If we users don't try to help each other, it won't happen. Not sure what happened to Steven and Buddy. Mysteries!

Curious though, did you attempt to reinstall to the emmc via an sd card?  I know the ARMBIAN OS has a feature that allows to flash to the emmc on some other SBCs.  

Always better late than never!  8-)
Thanks  [url=http://www.orangepi.org/orangepibbsen/static/image/smiley/default/biggrin.gif]http://ww
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2020-9-27 02:52 GMT+8 , Processed in 0.028213 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list