please choosego to mobile | Continue to access the PC version
Author: gaara

Mali GPU driver

[Copy link]

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-8-29 18:07:45 | Show all floors
zhao_steven replied at 2015-8-29 05:02
lib_mali_r4p0_DDK  download link
http://pan.baidu.com/s/1sjmlhI9

Hi Steven. Thanks for message )

Orange PI 2
www.orangepi.pp.ua

18

threads

303

posts

8816

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8816
Published in 2015-8-30 08:38:14 | Show all floors
magicse replied at 2015-8-29 18:07
Hi Steven. Thanks for message )

Is it working?

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-8-30 17:01:26 | Show all floors

Why not? It's direct from Mali.
Orange PI 2
www.orangepi.pp.ua

18

threads

303

posts

8816

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
8816
Published in 2015-9-1 08:32:13 | Show all floors
magicse replied at 2015-8-30 17:01
Why not? It's direct from Mali.

Hardware acceleration playback will be enabled then? That`s great news. We can install Kodi on Lubuntu then.

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-9-1 14:26:05 | Show all floors
Edited by magicse at 2015-9-1 19:57
jacer replied at 2015-9-1 02:32
Hardware acceleration playback will be enabled then? That`s great news. We can install Kodi on Lub ...

It's only GPU (2D, 3D acceleration) not VPU. Accelerating only XBMC interface )).
For VPU use different module CedarX

Orange PI 2
www.orangepi.pp.ua

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-9-2 20:35:29 | Show all floors

Hi Steven.
Could you send me 2 files from Lubuntu 1404 v 0.9.0?
1 .config
and
2 Module.symvers
Thanks.

Orange PI 2
www.orangepi.pp.ua

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-9-3 22:39:24 | Show all floors
zhao_steven replied at 2015-8-26 04:57
@magicse  I will release it.

Hi Steven.
Could you send me 2 files from Lubuntu 1404 v 0.9.0?
1 .config
and
2 Module.symvers
Thanks.
Orange PI 2
www.orangepi.pp.ua

4

threads

52

posts

284

credits

Intermediate member

Rank: 3Rank: 3

credits
284
Published in 2015-9-11 00:53:48 | Show all floors
Why is it so difficult to get it running? I get all kinds of compiling errors, no matter what distro I use on my OPI+. I do also have a pcduino3 nano (A20) where acceleration actually works on a Mali400, so it is possible... I really don't get it....

18

threads

200

posts

868

credits

Moderator

Rank: 7Rank: 7Rank: 7

credits
868
Published in 2015-9-11 19:51:39 | Show all floors

is

Edited by magicse at 2015-9-11 14:03
zhao_steven replied at 2015-8-26 04:57
@magicse  I will release it.

Steven hi there.
Could you give me ".config" file from kernel wich You build for Lubuntu 1404 0.9.0 ? And the same thing with file module.symvers. Pls. Without that file i cant build modules for your Lubuntu image.
Becuse i get another modules_layout crc then in your image, and cant insmod module.
By default config need be in /proc/config.gz but there is nothing (((
Correct me if I'm wrong
Orange PI 2
www.orangepi.pp.ua

0

threads

4

posts

86

credits

Registered member

Rank: 2

credits
86
Published in 2015-9-19 23:46:13 | Show all floors
Edited by xandey at 2015-9-19 23:48

I was able to get r3p2-01rel2 working with out x11.

I compiled the r3p2-01rel2 ump and mali kernel modules from the lichee release, then I installed the libump and sunxi-mali packages from linux-sunxi per http://linux-sunxi.org/Mali_binary_driver tutorial. The test.c from sunxi-mali seems to work and detects the correct gpu. (two small changes backported from teh r4p0 versions to support H3)
I had trouble compiling mali_drm for my kernel though, it looks like it needs 3.8? Anyway, for my purposes I don't need x11.

I was wondering if Steven has the non-x11 version of the binary blob from allwinner/mali ddk for r4p0 (or if anyone else has found it). I downloaded the baidu link, but it appears to only have the x11 version.

Oh, this was all on an OPI-Plus.
You need to log in before you can reply login | Register

Points Rule

Quick reply Top Return list