Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
12Next
Return to list New
View: 15052|Reply: 15

Orange PI PLUS: TV OUT no signal [SOLVED]

[Copy link]

1

Threads

6

Posts

811

Credits

Senior member

Rank: 4

Credits
811
Post time 2015-11-13 07:58:39 | Show all posts |Read mode
Edited by stp5k at 2015-11-24 11:00

Hi all,

I am using a standard AV cable bought from original supplier (Steven Zhao) It is a 2.5(sorry 3.5) jack to 3xRCA.
http://www.aliexpress.com/item/7 ... le/32248776760.html

I have tested Android (Original and Tronsmart image)  With default settings I get no signal on AV out.

In linux I tried forcing the AV out with following settings: (PAL)

[disp_init]
disp_init_enable = 1
disp_mode = 1
screen0_output_type = 3
screen0_output_mode = 4
screen1_output_type = 2
screen1_output_mode = 11
fb0_format = 0
fb0_width = 0
fb0_height = 0
fb1_format = 0
fb1_width = 0
fb1_height = 0

Can someone help me? Is there a way to test if it is a hardware or config problem?
thanks in advance.
Steven



[SOLUTION] Orange Pi PLUS > TRRS connector. After testing with multimeter.T (Left audio)
R (right audio) R (video)
S (Ground)



So the ground is on the sleave of the connector, ring2 is video, ring1 is right audio, tip is left audio

16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2015-11-13 10:30:55 | Show all posts
This is a sample config from fex guide:
  1. [disp_init]
  2. disp_init_enable = 1
  3. disp_mode = 0

  4. screen0_output_type = 2
  5. screen0_output_mode = 11

  6. screen1_output_type = 2
  7. screen1_output_mode = 11

  8. fb0_framebuffer_num = 2
  9. fb0_format = 10
  10. fb0_pixel_sequence = 0
  11. fb0_scaler_mode_enable = 1

  12. fb1_framebuffer_num = 2
  13. fb1_format = 10
  14. fb1_pixel_sequence = 0
  15. fb1_scaler_mode_enable = 1
Copy the Code

Hope may be of some help
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

8

Threads

54

Posts

364

Credits

Intermediate member

Rank: 3Rank: 3

Credits
364
Post time 2015-11-17 07:39:14 | Show all posts
tokka where do i poot this code??

16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2015-11-17 08:40:31 | Show all posts
You have to change theme in script.bin, using sunxi-fex
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

1

Threads

6

Posts

811

Credits

Senior member

Rank: 4

Credits
811
 Author| Post time 2015-11-17 14:33:26 | Show all posts
I am still not able to get AV out working. Is there a way I can test (voltmerer?)
Or see the device is recognised in the firmware? maybe I have shotty cable...


getting this output:>>

script config pll_de to 864 Mhz
Not Found clk pll_video1 in script
script config pll_video to 297 Mhz
[boot]disp_init_tv
[DISP_TV] disp_init_tv enter g_tv_used
screen 0 do not support TV TYPE!
[BOOOT_DISP_TV] disp tv device_registered
unable to find regulator vcc-hdmi-18 from [pmu1_regu] or [pmu2_regu]
enable power vcc-hdmi-18, ret=-1
DRV_DISP_Init end
boot_disp.auto_hpd=1
auto hpd check has 50 times!
[disk_read_fs] no the qartition
error: open disp_rsl.fex, maybe it is not exist
attched ok, mgr1<-->device1, type=2, mode=11----
ready to set mode
disp_tv_enable
[      1.450]finally, output_type=0x2, output_mode=0xb, screen_id=0x1, disp_para=0x20b0000
fail to find part named env
Using default environment



0

Threads

13

Posts

136

Credits

Registered member

Rank: 2

Credits
136
Post time 2015-11-17 17:23:07 | Show all posts
tokka replied at 2015-11-17 08:40
You have to change theme in script.bin, using sunxi-fex

how to do.....


This post contains more resources

You have to Login for download or view attachment(s). No Account? Register

x

8

Threads

54

Posts

364

Credits

Intermediate member

Rank: 3Rank: 3

Credits
364
Post time 2015-11-17 18:40:10 | Show all posts
https://github.com/milan285/orange/blob/master/orange_pi_pc.fex i think this should work if someone knew what goes on line #694
also when you finish it,make it into bin and post it on this site
i can't trasnform to bin because kali does't support it.

16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2015-11-17 23:16:53 | Show all posts
@ renpeng:
try with
./bin2fex /media/*/script-bin script.fex

@milan285:
tv_en =portI12<1><default><default><0>

but i don't remember that op has a tv encoder, or a tv (antenna) input/output
Maybe i'm wrong, but afaik the tv_para are for tv encoder/decoder, and disp_init are to tell to mali how and where send the video signal (singlehead, dualhead, xinerama, clone, and hdmi, vga, tv output).
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

8

Threads

54

Posts

364

Credits

Intermediate member

Rank: 3Rank: 3

Credits
364
Post time 2015-11-18 02:22:55 | Show all posts
i reworked the file,check the github and make it a bin file,send it to me

1

Threads

6

Posts

811

Credits

Senior member

Rank: 4

Credits
811
 Author| Post time 2015-11-19 09:18:12 | Show all posts
Edited by stp5k at 2015-11-19 11:50

Can someone confirm the "AV out" (3.5mm jack) should be working out of the box with android on the PI+
Since the "quick start" guide has instructions to just connect it...


This post has pinout:
Which TRRS cable
http://www.orangepi.org/orangepi ... &fromuid=195045
(from OrangePi)

Will test the cable with a multimeter...
12Next
Return to list New
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2021-10-17 07:16 GMT+8 , Processed in 0.035505 second(s), 23 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list