Please select To the mobile version | Continue to access the desktop computer version

OrangePi

 Login            
 Register            
Search
Hot search: orangepi
Author: Rangarid

VPU CedarX drivers for Allwinner H3

[Copy link]

8

Threads

55

Posts

252

Credits

Intermediate member

Rank: 3Rank: 3

Credits
252
Post time 2016-1-7 06:40:25 | Show all posts
Fritz,

The reason i get artifacts on pink (not purple) screen is because i'm running on OPI Plus 2 ( 2 GB RAM)!
It runs fine on OPI-PC and also runs fine with VDPAU 0.7 (H265 removed) on previous mplayer version.

If anyone could help finding the right ion memory config, please, be my guest!

@lex

8

Threads

55

Posts

252

Credits

Intermediate member

Rank: 3Rank: 3

Credits
252
Post time 2016-1-9 05:49:58 | Show all posts
Can you tell if you get sound output to hdmi while using mpv?
I have sndhdmi working but cannot get sound output (hdmi and pcm) with mpv or mplayer, alsa is working when tested, any suggestion?

16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2016-1-9 18:06:01 | Show all posts
@ @alex: have you looked at /etc/mplayer/mplayer.conf ?
may be the default audio ouput is set to oss.
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

0

Threads

2

Posts

24

Credits

Novice

Rank: 1

Credits
24
Post time 2016-1-9 18:45:49 | Show all posts
@lex (and others too), please report such libvdpau-sunxi issues at github. They usually can be fixed easily and everyone will be happy, but I don't want to dig through all the different *pi forums to find them.

https://github.com/linux-sunxi/libvdpau-sunxi/

8

Threads

55

Posts

252

Credits

Intermediate member

Rank: 3Rank: 3

Credits
252
Post time 2016-1-9 21:30:47 | Show all posts
jemk replied at 2016-1-9 07:45
@lex (and others too), please report such libvdpau-sunxi issues at github. They usually can be fixed ...

Thank you jemk, i just opened the issue there.

8

Threads

55

Posts

252

Credits

Intermediate member

Rank: 3Rank: 3

Credits
252
Post time 2016-1-9 21:37:53 | Show all posts
tokka replied at 2016-1-9 07:06
@ @alex: have you looked at /etc/mplayer/mplayer.conf ?
may be the default audio ouput is set to oss ...

Hi Tokka,
The sndhdmi is working as expected:
  1. aplay -D hw:1 /usr/share/sounds/alsa/Front_Center.wav
  2. Playing WAVE '/usr/share/sounds/alsa/Front_Center.wav' : Signed 16 bit Little Endian, Rate 48000 Hz, Mono
Copy the Code

humm, maybe is user permission issue? I don't have /etc/mplayer. Anything else i should check? By the way, you have sound output to hdmi?

  1. mplayer -fs -vo vdpau -vc ffmpeg12vdpau,ffh264vdpau, bbb_sunflower_1080p_30fps_normal.mp4
  2. MPlayer2 2.0-701-gd4c5b7f-2ubuntu2 (C) 2000-2012 MPlayer Team
  3. Cannot open file '/home/ubuntu/.mplayer/input.conf': No such file or directory
  4. Failed to open /home/ubuntu/.mplayer/input.conf.
  5. Cannot open file '/etc/mplayer/input.conf': No such file or directory
  6. Failed to open /etc/mplayer/input.conf.

  7. Playing bbb_sunflower_1080p_30fps_normal.mp4.
  8. Detected file format: QuickTime / MOV (libavformat)
  9. [lavf] stream 0: video (h264), -vid 0
  10. [lavf] stream 1: audio (mp3), -aid 0, -alang und
  11. [lavf] stream 2: audio (ac3), -aid 1, -alang und
  12. Clip info:
  13. major_brand: isom
  14. minor_version: 1
  15. compatible_brands: isomavc1
  16. creation_time: 2013-12-16 17:44:39
  17. title: Big Buck Bunny, Sunflower version
  18. artist: Blender Foundation 2008, Janus Bager Kristensen 2013
  19. comment: Creative Commons Attribution 3.0 - http://bbb3d.renderfarming.net
  20. genre: Animation
  21. composer: Sacha Goedegebure
  22. Load subtitles in .
  23. [VDPAU SUNXI] VE version 0x1680 opened.
  24. Forced video codec: ffmpeg12vdpau
  25. Forced video codec: ffh264vdpau
  26. Selected video codec: H.264 / AVC / MPEG-4 AVC / MPEG-4 part 10 (VDPAU acceleration) [libavcodec]
  27. Selected audio codec: MPEG 1.0/2.0/2.5 layers I, II, III [mpg123]
  28. AUDIO: 48000 Hz, 2 ch, s16le, 160.0 kbit/10.42% (ratio: 20000->192000)
  29. AO: [pulse] 48000Hz 2ch s16le (2 bytes per sample)
  30. Starting playback...
  31. VIDEO:  1920x1080  30.000 fps  2998.7 kbps (374.8 kB/s)
  32. VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration  [fs]
  33. [vdpau] Failed to get display FPS
  34. VIDEO:  1920x1080  30.000 fps  2998.7 kbps (374.8 kB/s)
  35. VO: [vdpau] 1920x1080 => 1920x1080 H.264 VDPAU acceleration  [fs]
  36. [vdpau] Failed to get display FPS
  37. [VDPAU SUNXI] Presentation time not supported
  38. A:   2.4 V:   2.4 A-V: -0.000 ct: -0.000   0/  0 73% 12%  3.6% 12 0

  39. Exiting... (Quit)
Copy the Code






16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2016-1-11 09:11:08 | Show all posts
Edited by tokka at 2016-1-11 09:12

Yes, i  have hdmi sound...but i have only op A20
Are you using a self compiled mplayer, or the default one?
BTW, try to make an "input.conf" file in .mplayer folder (/home/ubuntu/.mplayer/input.conf  or /etc/mplayer/input.conf)  and try to paste in it
  1. ao=pulse,alsa,sdl:aalib
Copy the Code
and check if it works.

here is my mplayer.conf if you wanna give a look
  1. #
  2. # MPlayer configuration file
  3. #
  4. # Configuration files are read system-wide from /etc/mplayer/mplayer.conf
  5. # and per user from ~/.mplayer/config, where per-user settings override
  6. # system-wide settings, all of which are overrriden by the command line.
  7. #
  8. # The configuration file settings are the same as the command line
  9. # options without the preceding '-'.
  10. #
  11. # See the CONFIGURATION FILES section in the man page
  12. # for a detailed description of the syntax.


  13. ##################
  14. # video settings #
  15. ##################

  16. # Specify default video driver (see -vo help for a list).
  17. # vo=xv,x11

  18. # FBdev driver:
  19. #
  20. # mode to use (read from fb.modes)
  21. #fbmode = 640x480-120
  22. #
  23. # location of the fb.modes file
  24. #fbmodeconfig = /etc/fb.modes

  25. # Specify your monitor timings for the vesa and fbdev video output drivers.
  26. # See /etc/X11/XF86Config for timings. Be careful; if you specify settings
  27. # that exceed the capabilities of your monitor, you may damage it.
  28. #
  29. # horizontal frequency range (k stands for 1000)
  30. #monitor-hfreq = 31.5k-50k,70k
  31. #
  32. # vertical frequency range
  33. #monitor-vfreq = 50-90
  34. #
  35. # dotclock (or pixelclock) range (m stands for 1000000)
  36. #monitor-dotclock = 30M-300M

  37. # Start in fullscreen mode by default.
  38. fs=yes

  39. # Change to a different videomode when going fullscreen.
  40. #vm=yes

  41. # Override the autodetected color depth, may need 'vm=yes' as well.
  42. #bpp=0

  43. # Enable software scaling (powerful CPU needed) for video output
  44. # drivers that do not support hardware scaling.
  45. #zoom=yes

  46. # standard monitor size, with square pixels
  47. #monitoraspect=4:3

  48. # Use this for a widescreen monitor, non-square pixels.
  49. #monitoraspect=16:9

  50. # Keep the player window on top of all other windows.
  51. #ontop=yes


  52. ##################
  53. # audio settings #
  54. ##################

  55. # Use pulse, then alsa, then SDL video with the aalib subdriver by default.
  56. ao=pulse,alsa,sdl:aalib

  57. # Use SDL audio driver with the esd subdriver by default.
  58. #ao = sdl:esd

  59. # Specify the mixer device.
  60. #mixer = /dev/mixer

  61. # Resample the sound to 44100Hz with the lavcresample audio filter.
  62. #af=lavcresample=44100


  63. ##################
  64. # other settings #
  65. ##################

  66. stop-xscreensaver=yes

  67. # Joystick input is disabled because of issues on some laptops(thinkpad).
  68. joystick=no

  69. # Pretend to be Window Media Player.
  70. # Fixes playback when playlist and media file use the same URL.
  71. #user-agent=NSPlayer/4.1.0.3856

  72. # Drop frames to preserve audio/video sync.
  73. #framedrop = yes

  74. # Specify your preferred skin here (skins are searched for in
  75. # /usr/local/share/mplayer/skins/<name> and ~/.mplayer/skins/<name>).
  76. #skin = Abyss

  77. # Resample the font alphamap.
  78. # 0     plain white fonts
  79. # 0.75  very narrow black outline (default)
  80. # 1     narrow black outline
  81. # 10    bold black outline
  82. #ffactor = 0.75

  83. # cache settings
  84. #
  85. # Use 8MB input cache by default.
  86. cache = 8192
  87. #
  88. # Prefill 20% of the cache before starting playback.
  89. #cache-min = 20.0
  90. #
  91. # Prefill 50% of the cache before restarting playback after the cache emptied.
  92. #cache-seek-min = 50

  93. # DVD: Display English subtitles if available.
  94. #slang = en

  95. # DVD: Play English audio tracks if available.
  96. #alang = en

  97. ###################
  98. # DVDNAV Settings #
  99. ###################
  100. #vc=ffmpeg12,

  101. # You can also include other configuration files.
  102. #include = /path/to/the/file/you/want/to/include
Copy the Code


OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

8

Threads

55

Posts

252

Credits

Intermediate member

Rank: 3Rank: 3

Credits
252
Post time 2016-1-15 07:33:20 | Show all posts
tokka replied at 2016-1-10 22:11
Yes, i  have hdmi sound...but i have only op A20
Are you using a self compiled mplayer, or the de ...

@Tokka,
I tried your conf without success, no hdmi sound output.
Since this has nothing to do with video decoding i will stop here, but i would like to hear somenone that has hdmi sound output fully working on H3.
@lex

16

Threads

105

Posts

989

Credits

Senior member

Rank: 4

Credits
989
Post time 2016-1-15 16:12:03 | Show all posts
@ @lex,
have you tried as user and as root too? both give you the same result?
Tk
OrangePi A20, with Qbee-X_testing

Still waiting for refund/replacement of no working op+2e bought on 11/11 >_<...really serious company

1

Threads

6

Posts

135

Credits

Moderator

Rank: 7Rank: 7Rank: 7

Credits
135
Post time 2016-5-14 11:58:31 | Show all posts
does the VDPAU implementation support encoding of h.264?
You have to log in before you can reply Login | Register

Points Rules

Archiver|Mobile edition|Darkroom|OrangePi En ( 粤ICP备14086627号-2

2022-5-22 08:20 GMT+8 , Processed in 0.032820 second(s), 20 queries .

Powered by Discuz! X3.2

© 2014-2015 orangepibbs en.

Quick Reply To Top Return to the list